#1375 Complaint about LuaExpat version >= 1.3.0 highly recommended, but 1.3.3 installed
What steps will reproduce the problem?
execute $ prosodyctl about
What is the expected output?
Information about prosody, the lua modules it uses, etc.
What do you see instead?
In addition, before the regular output, I see the error
"general error The version of LuaExpat on your system does not support stanza size limits, which may leave servers on untrusted networks (e.g. the internet) vulnerable to denial-of-service attacks. You should upgrade to LuaExpat 1.3.0 or higher as soon as possible. See https://prosody.im/doc/depends#luaexpat for more information."
Further down, however prosodyctl tells me I am using
# Lua module versions
lfs: LuaFileSystem 1.7.0
lxp: LuaExpat 1.3.3
socket: LuaSocket 3.0-rc1
What version of the product are you using? On what operating system?
I use prosody 0.11.2 on a shared host with CentOS 6, linux kernel 2.6.32.
I installed prosody via "toast" on that shared host. The lua modules were installed via luarocks.
Please provide any additional information below.
How can prosodyctl register lxp==1.3.3 but complain about it being <=1.3.0 ?
Did I mess up something with my luapath? But even if so, its complaint should not be inconsistent with what it registers …
In the past I did not see this error message. I cannot tell you exactly when it appeared.
Hi, thanks for the report!
This is an awkward one. Another person has made a 1.3.3 release and uploaded it to LuaRocks. Prosody is correct to complain: it does not implement the feature that Prosody requires.
I will contact the uploader of that version and see if we can resolve this.