#243 liblua5.1-dbi0 can't install on Debian squeeze/Ubuntu
Reporter
charlesroth
Owner
MattJ
Created
Updated
Stars
★★★ (4)
Tags
OpSys-Linux
Type-Task
Usability
Priority-High
Status-Fixed
charlesroth
on
*What steps will reproduce the problem?*
1. dependency available in ubuntu or prosody repo
*2.*
*3.*
What is the expected output? What do you see instead? liblua5.1-dbi0: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installable
*What version of the product are you using? On what operating system?*
Prosody 0.8.0 on Ubuntu 10.04 LTS server
*Please provide any additional information below.*
MattJ
on
Hi, thanks for the report.
This is a known issue with the luadbi in our repository, sadly fixing it is proving difficult as it requires major changes to our build server, it seems. It's a work in progress.
However you're lucky, for Ubuntu there is a solution. Add this PPA to your system as per the instructions: https://launchpad.net/~prosody-dev/+archive/ppa
Run: sudo apt-get update, then sudo apt-get install liblua5.1-dbi0
Hope this helps,
Matthew
title liblua5.1-dbi0 can't install on Debian squeeze/Ubuntu
supertoto.dom
on
Hi
Why not open the dependency like 'libmysqlclient15off (>= 5.0.27-1) | libmysqlclient16', the first for old Ubuntu (I hope), the second for new Debian.
You don't have anythig to change in your server configuration...
Thanks for your excellent software.
I hope I can install it quickly on my new Debian Squeeze !
MattJ
on
That works for the source package for building, but once the binary package is built it has to depend on a specific version of libmysqlclient. We don't have the building or serving of multiple binary packages working at the moment.
What would be great is if Debian supported PPAs like Ubuntu...
ky6uk.kun
on
Installation process on Debian squeeze has been terminated with return code 127 and with no any reasons. This is issue with "liblua5.1-dbi0" can be affecting on me? I use prosody main repo.
MattJ
on
A small update on this. LuaDBI is now officially packaged in Debian's own repositories. This means it is in testing, and will be available in the next stable release.
I've also uploaded packages to the PPA for newer versions of Ubuntu.
Updated instructions for all currently supported platforms are at: http://prosody.im/doc/depends#luadbi
Unfortunately as far as I know none of these packages work on Debian 6.0 (current stable), so I still need to work on that after the 0.9 release.
squalyl
on
hello, any news on that bug? This is still preventing me to install prosody on debian 6.
thanks!
MattJ
on
This is now fixed since we switched to the new package repository and builder. Install LuaDBI from our repository according to the instructions here: http://prosody.im/doc/depends#luadbi
Our repository currently still supports squeeze, and lua-dbi is available in wheezy's official repositories anyway, but never mind :)
*What steps will reproduce the problem?* 1. dependency available in ubuntu or prosody repo *2.* *3.* What is the expected output? What do you see instead? liblua5.1-dbi0: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installable *What version of the product are you using? On what operating system?* Prosody 0.8.0 on Ubuntu 10.04 LTS server *Please provide any additional information below.*
Hi, thanks for the report. This is a known issue with the luadbi in our repository, sadly fixing it is proving difficult as it requires major changes to our build server, it seems. It's a work in progress. However you're lucky, for Ubuntu there is a solution. Add this PPA to your system as per the instructions: https://launchpad.net/~prosody-dev/+archive/ppa Run: sudo apt-get update, then sudo apt-get install liblua5.1-dbi0 Hope this helps, Matthew
ChangesType-DefectPriority-MediumType-Task Priority-High OpSys-Linux Usability Status-AcceptedHi Why not open the dependency like 'libmysqlclient15off (>= 5.0.27-1) | libmysqlclient16', the first for old Ubuntu (I hope), the second for new Debian. You don't have anythig to change in your server configuration... Thanks for your excellent software. I hope I can install it quickly on my new Debian Squeeze !
That works for the source package for building, but once the binary package is built it has to depend on a specific version of libmysqlclient. We don't have the building or serving of multiple binary packages working at the moment. What would be great is if Debian supported PPAs like Ubuntu...
Installation process on Debian squeeze has been terminated with return code 127 and with no any reasons. This is issue with "liblua5.1-dbi0" can be affecting on me? I use prosody main repo.
A small update on this. LuaDBI is now officially packaged in Debian's own repositories. This means it is in testing, and will be available in the next stable release. I've also uploaded packages to the PPA for newer versions of Ubuntu. Updated instructions for all currently supported platforms are at: http://prosody.im/doc/depends#luadbi Unfortunately as far as I know none of these packages work on Debian 6.0 (current stable), so I still need to work on that after the 0.9 release.
hello, any news on that bug? This is still preventing me to install prosody on debian 6. thanks!
This is now fixed since we switched to the new package repository and builder. Install LuaDBI from our repository according to the instructions here: http://prosody.im/doc/depends#luadbi Our repository currently still supports squeeze, and lua-dbi is available in wheezy's official repositories anyway, but never mind :)
Changes