#1747 Ubuntu package requires C/C++ compiler and development packages

Reporter xvitaly
Owner Nobody
Created
Updated
Stars ★ (1)
Tags
  • Status-Duplicate
  • Type-Defect
  • Priority-Medium
  1. xvitaly on

    What steps will reproduce the problem? 1. Install/upgrade prosody package from the official repository on Ubuntu 20.04 LTS. 2. 3. What is the expected output? Package should not require C/C++ compilers and other development packages. Version 0.11.13-1~focal1 doesn't require any development packages, while 0.12.0-1~focal1 does. What do you see instead? $ sudo apt dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following NEW packages will be installed: autoconf automake autotools-dev binutils binutils-common binutils-x86-64-linux-gnu cpp cpp-9 gcc gcc-9 gcc-9-base libasan5 libatomic1 libbinutils libc-dev-bin libc6-dev libcc1-0 libcrypt-dev libctf-nobfd0 libctf0 libdpkg-perl libfile-fcntllock-perl libgcc-9-dev libisl22 libitm1 liblsan0 libltdl-dev liblua5.1-0 liblua5.1-0-dev libmpc3 libncurses-dev libquadmath0 libreadline-dev libtool libtool-bin libubsan1 linux-libc-dev lua-any luarocks m4 manpages-dev pkg-config zip The following packages will be upgraded: prosody 1 upgraded, 43 newly installed, 0 to remove and 0 not upgraded. Need to get 35.0 MB of archives. After this operation, 157 MB of additional disk space will be used. Do you want to continue? [Y/n] What version of the product are you using? On what operating system? Prosody: 0.12.0-1~focal1 Ubuntu: 20.04 LTS Please provide any additional information below.

  2. MattJ on

    Hi, thanks for the report. I can't reproduce this issue. And 'apt dist-upgrade' is expected to upgrade all your packages on your system. To upgrade only Prosody, run: 'sudo apt install prosody'. If the same issue occurs with that command, please share the output of 'apt policy prosody'. Thanks!

  3. xvitaly on

    > I can't reproduce this issue. And 'apt dist-upgrade' is expected to upgrade all your packages on your system. I already updated all packages with dist-upgrade, excluding prosody. > To upgrade only Prosody, run: 'sudo apt install prosody'. The same. Apt asks to install all these development packages: $ sudo apt install prosody Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: autoconf automake autotools-dev binutils binutils-common binutils-x86-64-linux-gnu cpp cpp-9 gcc gcc-9 gcc-9-base libasan5 libatomic1 libbinutils libc-dev-bin libc6-dev libcc1-0 libcrypt-dev libctf-nobfd0 libctf0 libdpkg-perl libfile-fcntllock-perl libgcc-9-dev libisl22 libitm1 liblsan0 libltdl-dev liblua5.1-0 liblua5.1-0-dev libmpc3 libncurses-dev libquadmath0 libreadline-dev libtool libtool-bin libubsan1 linux-libc-dev lua-any luarocks m4 manpages-dev pkg-config zip Suggested packages: autoconf-archive gnu-standards autoconf-doc gettext binutils-doc cpp-doc gcc-9-locales gcc-multilib make flex bison gdb gcc-doc gcc-9-multilib gcc-9-doc glibc-doc debian-keyring git bzr libtool-doc ncurses-doc readline-doc gfortran | fortran95-compiler gcj-jdk m4-doc dpkg-dev lua-bitop | lua-bit32 lua-dbi-postgresql lua-ldap Recommended packages: lua-readline lua-unbound The following NEW packages will be installed: autoconf automake autotools-dev binutils binutils-common binutils-x86-64-linux-gnu cpp cpp-9 gcc gcc-9 gcc-9-base libasan5 libatomic1 libbinutils libc-dev-bin libc6-dev libcc1-0 libcrypt-dev libctf-nobfd0 libctf0 libdpkg-perl libfile-fcntllock-perl libgcc-9-dev libisl22 libitm1 liblsan0 libltdl-dev liblua5.1-0 liblua5.1-0-dev libmpc3 libncurses-dev libquadmath0 libreadline-dev libtool libtool-bin libubsan1 linux-libc-dev lua-any luarocks m4 manpages-dev pkg-config zip The following packages will be upgraded: prosody 1 upgraded, 43 newly installed, 0 to remove and 0 not upgraded. Need to get 35.0 MB of archives. After this operation, 157 MB of additional disk space will be used. Do you want to continue? [Y/n] > If the same issue occurs with that command, please share the output of 'apt policy prosody'. Thanks! $ sudo apt policy prosody prosody: Installed: 0.11.13-1~focal1 Candidate: 0.12.0-1~focal1 Version table: 0.12.0-1~focal1 500 500 http://packages.prosody.im/debian focal/main amd64 Packages *** 0.11.13-1~focal1 100 100 /var/lib/dpkg/status 0.11.4-1 500 500 http://it.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

  4. Zash on

    This happens because of the optional (Recommends) dependency on luarocks, which in turn optionally depends on compiler tools. This is because it can install packages ("rocks") in source form that need compiling. Since all this is optional you should be able to disable installation of those optional packages by running 'apt install prosody --no-install-recommends'.

  5. xvitaly on

    Executing apt-mark hold luarocks fixed this issue for me. Many thanks. This issue can be closed now.

  6. Zash on

    Thanks. See also #1707 and https://github.com/luarocks/luarocks/issues/1275

    Changes
    • tags Status-Duplicate

New comment

Not published. Used for spam prevention and optional update notifications.