#1353 configure fails to find lua.h if it sees /bin/lua first

Reporter Zash
Owner Zash
Created
Updated
Stars ★★ (2)
Tags
  • Component-Scripts
  • Milestone-0.11
  • Type-Defect
  • Status-Fixed
  • Priority-Medium
  1. Zash on

    trunk$ sudo ln -s /usr/bin/lua /bin/lua trunk$ PATH=/bin:/usr/bin ./configure Lua version detected: 5.2 Lua interpreter found: /bin/lua... Looking for lua.h at //include/lua.h...not found Looking for lua.h at //include/lua/5.2/lua.h...not found Looking for lua.h at //include/lua5.2/lua.h...not found Looking for lua.h at //include/lua/lua.h...not found Looking for lua.h at //include/lua/lua.h...not found lua.h not found. You may want to use the flag --with-lua or --with-lua-include. See --help. configure failed. Happens on CentOS 7

  2. Robert Scheck on

    On CentOS 7, /bin is a symlink to /usr/bin due to https://fedoraproject.org/wiki/Features/UsrMove (note that CentOS 7 has Lua 5.1, not 5.2). The workaround for the EPEL package is --prefix=/usr for ./configure in prosody.spec.

  3. Zash on

    Workaround added in https://hg.prosody.im/trunk/rev/c8646f65767a

    Changes
    • owner Zash
    • tags Milestone-0.11 Component-Scripts Status-Fixed

New comment

Not published. Used for spam prevention and optional update notifications.