#1375 Complaint about LuaExpat version >= 1.3.0 highly recommended, but 1.3.3 installed

Reporter adoa
Owner MattJ
Stars ★★★ (4)
  • Status-Accepted
  • Priority-Medium
  • Type-Defect
  1. adoa on

    What steps will reproduce the problem? execute $ prosodyctl about What is the expected output? Information about prosody, the lua modules it uses, etc. What do you see instead? In addition, before the regular output, I see the error "general error The version of LuaExpat on your system does not support stanza size limits, which may leave servers on untrusted networks (e.g. the internet) vulnerable to denial-of-service attacks. You should upgrade to LuaExpat 1.3.0 or higher as soon as possible. See https://prosody.im/doc/depends#luaexpat for more information." Further down, however prosodyctl tells me I am using # Lua module versions lfs: LuaFileSystem 1.7.0 libevent: 2.1.8-stable luaevent: 0.4.6 lxp: LuaExpat 1.3.3 socket: LuaSocket 3.0-rc1 ssl: 0.6 What version of the product are you using? On what operating system? I use prosody 0.11.2 on a shared host with CentOS 6, linux kernel 2.6.32. I installed prosody via "toast" on that shared host. The lua modules were installed via luarocks. Please provide any additional information below. How can prosodyctl register lxp==1.3.3 but complain about it being <=1.3.0 ? Did I mess up something with my luapath? But even if so, its complaint should not be inconsistent with what it registers … In the past I did not see this error message. I cannot tell you exactly when it appeared.

  2. MattJ on

    Hi, thanks for the report! This is an awkward one. Another person has made a 1.3.3 release and uploaded it to LuaRocks. Prosody is correct to complain: it does not implement the feature that Prosody requires. I will contact the uploader of that version and see if we can resolve this.

    • owner MattJ
    • tags Status-Accepted
  3. Tobias Klausmann on

    Has there been any news on this? Distributions are shipping 1.3.3 now in favor of 1.3.0, and as a result, at a minimum the tests break: $ make -j4 test busted --lua=lua ●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●● ●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●✱ 291 successes / 0 failures / 1 error / 0 pending : 0.224559 seconds Error → ./util/xmppstream.lua @ 21 suite spec/util_xmppstream_spec.lua ./util/xmppstream.lua:21: attempt to index local 'lxp' (a boolean value) make: *** [Makefile:72: test] Error 1 Though this may be of course unrelated, but changing the inherit logic from returning a table to just nothing (and thus inherit just returning a bool) sounds like a lxp packagin/compatibility/api issue.

  4. MattJ on

    Hi Tobias, Which distributions?

  5. Conrad Kostecki on

    The problem is libexpat-1.3.3. The stable release version does not include the needed method, which was merged AFTER 1.3.3 release: https://github.com/tomasguisasola/luaexpat/issues/3 After patching libexpat-1.3.3 with the needed patch https://github.com/tomasguisasola/luaexpat/commit/0926f2d705109b7d35b721344264b39c1169e0de, prosody works fine and no warning about libexpat is being shown. But the problem with a broken test exists. Running with 1.3.3 (or 1.3.3 with patch) does result in one test being failed: ./util/xmppstream.lua:21: attempt to index local 'lxp' (a boolean value) All tests pass with running with 1.3.0.

  6. Conrad Kostecki on

    Argh, i mean luaexpat-1.3.3 instead of libexpat-1.3.3, sorry.

New comment

Not published. Used for spam prevention and optional update notifications.