#1742 Installation fails on Ubuntu 22.04

Reporter Elliot Cooper
Owner Nobody
Stars ★ (1)
  • Component-Packages
  • Type-Defect
  • Dist-Ubuntu
  • Priority-Medium
  • OpSys-Linux
  • Status-NeedInfo
  1. Elliot Cooper on

    What steps will reproduce the problem? 1. Install Prosody on Ubuntu 22.04 What is the expected output? That Prosody will install with the apt package manager. What do you see instead? apt reports the following error: "The following packages have unmet dependencies: prosody : Depends: libicu67 (>= 67.1-1~) but it is not installable" The version of libicu available in Ubuntu 22.04 is libicu70 but this doesn't meet the package dependencies. Installing libicu67 with the .deb resolves the issue. What version of the product are you using? On what operating system? Ubuntu 22.04 Prosody: 0.12.0-1~jammy1 Please provide any additional information below. Thanks!

  2. Zash on

    Thanks for the report! Looks like libicu was updated in Ubuntu 22.04 shortly before the release and our build infrastructure had not updated, which is actually a manual thing that has yet to be automated. Normally this isn't a problem since released versions of Debian and Ubuntu are Stable™ and the versions of things don't really change. On the other hand, pre-release versions of Debian and Ubuntu (unstable, testing, sid and jammy until it's released) are updated more frequently, which may break our packages for a time, like happened here. I have refreshed the build environments in our package builder infrastructure, going to try to rebuild the package. Otherwise it's probably time for a 0.12.1 soon-ish anyway.

    • tags Dist-Ubuntu OpSys-Linux Component-Packages Status-Started
  3. Zash on

    Let's see how this goes: https://package-builder.prosody.im/#/builders/5/builds/1822

  4. Zash on

    New packages uploaded, please test and report back

    • tags Status-NeedInfo

New comment

Not published. Used for spam prevention and optional update notifications.